Delayed Similarity Report Generation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have experienced delays with Similarity Report processing in Turnitin, TurnitinUK, iThenticate, Crossref similarity check today. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT: April 3rd 21:53 - April 4th 00:08
BST: April 4th 05:53 - April 4th 08:08
AEST: April 4th 14:53 - April 4th 17:08

Please accept our apologies if you were impacted by today’s incident.
Posted Apr 04, 2022 - 01:27 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2022 - 23:49 PDT
Identified
We’ve run into some issues.

Turnitin, TurnitinUK, iThenticate, and users accessing these services via an integration are currently experiencing an unexpected service incident.

During this time, you may find that submissions take longer than expected to generate Similarity Reports.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Apr 03, 2022 - 22:45 PDT
This incident affected: iThenticate (iThenticate Report Processing Time), Crossref Similarity Check ((v1) Similarity Reports Generation), Turnitin (Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Report Processing Time).