Unexpected service incident
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have been unable to login into iThenticate today. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PST: December 27th 22:21 - December 28th 01:35
GMT: December 28th 06:21 - December 28th 09:35
AEDT : December 28th 17:21 - December 28th 20:35

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Dec 28, 2022 - 02:08 PST
Identified
We’ve run into some issues.

iThenticate is currently experiencing an unexpected service incident.

During this time, you may find slowness and issues logging into the iThenticate website.

Users also accessing these services via an integration may also be affected.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Dec 28, 2022 - 00:22 PST
This incident affected: iThenticate (iThenticate Website, iThenticate Report Processing Time, iThenticate API).