Unexpected service degradation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have experienced slower Similarity Report generation times in TurnitinUK, Turnitin.com and iThenticate. We are pleased to advise the service has been restored.

The incident occurred between the following times:

PST: February 19th 22:13 - February 20th 03:40
GMT: February 20th 06:13 - February 20th 11:40
AEDT: February 20th 17:13 - February 20th 22:40

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Feb 20, 2023 - 04:00 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 20, 2023 - 01:03 PST
Investigating
We’ve run into some issues.

The report generation speed is improving, however some users may still be experiencing slower Similarity Report generation times in Turnitin.com, TurnitinUK.com, and iThenticate.

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Feb 20, 2023 - 00:59 PST
This incident affected: iThenticate (iThenticate Report Processing Time), Crossref Similarity Check ((v1) Similarity Reports Generation), Turnitin (Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Report Processing Time).