Turnitin Service Incident - 03 May
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have experienced delays in Similarity Report generation when accessing via iThenticate V1 and CrossRef today. We are pleased to advise that service has been restored.

The incident occurred between the following times:

May 2nd 08:30 PDT - May 3rd 04:35 PDT
May 2nd 16:30 BST - May 3rd 12:35 BST
May 3rd 01:30 AEDT - May 3rd 21:35 AEDT

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted May 03, 2024 - 05:00 PDT
Identified
We’ve run into some issues.

iThenticate V1 and CrossRef are currently experiencing an unexpected service incident.

During this time, you may find delays with Similarity Report generation.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted May 03, 2024 - 03:10 PDT
This incident affected: iThenticate (iThenticate Report Processing Time) and Crossref Similarity Check ((v1) Similarity Reports Generation).