Turnitin Status Notification
Incident Report for Turnitin
Resolved
Due to an unexpected outage on our primary network circuit provider, you may have been unable to access Turnitin or iThenticate today. Some users may have been able to access these services but would have experienced degraded performance. Users accessing Turnitin via integrations were also impacted by this disruption. We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PDT April 21st 07:08 - 08:54 
BST April 21st 15:08 - 16:54
AEST April 22nd 00:08 - 01:54

Please accept our apologies if you were impacted by today’s disruption.
Posted Apr 21, 2020 - 09:11 PDT
Monitoring
We believe an issue with our network provider is the root cause of the current disruption. We are working on rerouting traffic now, which should restore full functionality.
Posted Apr 21, 2020 - 08:39 PDT
Update
Users of Turnitin and iThenticate may be intermittently unable to access these services or experience degraded performance once logged in. Users accessing these services via an integration may also be experiencing issues. We’re working to resolve this issue as quickly as possible. Apologies for any inconvenience this may be causing.
Posted Apr 21, 2020 - 08:20 PDT
Investigating
We’ve run into some issues.

Turnitin and iThenticate are currently experiencing an unexpected service disruption.

During this time, you may find that you are unable to access these services or experience degraded performance once logged in.

We invite you to track the progress of this disruption while we work to bring service back to optimum health.
Posted Apr 21, 2020 - 07:41 PDT
This incident affected: iThenticate (iThenticate Website, iThenticate Report Processing Time) and Turnitin (Turnitin Logins, Turnitin Paper Submissions, Turnitin Report Processing Time, Turnitin Feedback Studio Access).