Unexpected Service Degradation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users of Turnitin may have been unable to create a Turnitin assignment via the LTI External Tool.

We are, however, pleased to advise that service has been restored.

We have also received reports that submissions made during this period aren't currently accessible from LMS grading services, we are working to resolve this.

The incident occurred between the following times:

PDT September 29th 11:50 - September 30th 10:07
BST September 29th 19:50 - September 30th 18:07
AEST September 30th 04:50 - October 1st 2021 03:07

Please accept our apologies if you were impacted by today’s incident.
Posted Sep 30, 2021 - 11:52 PDT
Monitoring
A fix has been implemented and we are monitoring the results.

During this time, users should now be able to create Turnitin assignment via the LTI External tool.

We invite you to track the progress of this incident while we work to bring the service back to optimum health. We apologize for the inconvenience and thank you for your patience.
Posted Sep 30, 2021 - 10:39 PDT
Identified
The issue has been identified, and we are working to implement a fix.

During this time, users may be unable to create Turnitin assignment via the LTI External tool.

We invite you to track the progress of this incident while we work to bring the service back to optimum health. We apologize for the inconvenience and thank you for your patience.
Posted Sep 30, 2021 - 10:21 PDT
Investigating
Turnitin is currently experiencing an unexpected service degradation.

During this time, users may be unable to create Turnitin assignment via the LTI External tool.

We invite you to track the progress of this incident while we work to bring the service back to optimum health. We apologize for the inconvenience and thank you for your patience.
Posted Sep 30, 2021 - 10:06 PDT
This incident affected: Turnitin (Turnitin.com) and Turnitin UK (Turnitinuk.com).