Report generation issue
Incident Report for Turnitin
Resolved
We've fixed it!

Due to an unexpected service incident, users of Turnitin and Turnitin UK, experienced slower than usual Similarity Report generation speeds. Users accessing these services via an integration may also have been affected.

However, we are pleased to advise that the service has now been restored for Turnitin and TurnitinUK.

We are continuing to work through a backlog of submissions that were affected by this incident, but new submissions will not be affected.

The incident occurred between the following times:

PDT May 31st 10:30 - May 31st 14:22
BST: May 31st 18:30 - May 31st 22:22
AEST: June 1st 03:30 - June 1st 07:22

Please accept our apologies if you were impacted by today’s incident.
Posted May 31, 2022 - 15:09 PDT
Investigating
We’ve run into some issues.

Users of turnitin.com and turnitinuk.com are currently experiencing an unexpected service incident.

Users also accessing these services via an integration may also be affected. During this time, users may be experiencing slower than normal report generation times.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted May 31, 2022 - 13:15 PDT
This incident affected: Turnitin UK (Turnitin UK Report Processing Time) and Turnitin (Turnitin Report Processing Time).