Slow Similarity Report generation and Google SSO Login issues
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users of Turnitin.com, TurnitinUK.com, iThenticate, SimCheck, Similarity and Originality, as well as those accessing these services via an integration, may have been unable to log in via Google SSO, and experienced slow report generation times today. We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PST Feb 22 06:30 - Feb 22 09:10
GMT Feb 22 14:30- Feb 22 17:10
AEDT Feb 23 01:30 - Feb 23 04:10

Please accept our apologies if you were impacted by today’s disruption.
Posted Feb 22, 2021 - 09:22 PST
Identified
The earlier reported issue affecting users logging in to our services via Google SSO has now been resolved.

We are continuing to investigate the issue affecting Similarity Report generation across all services.

Please accept our apologies for any inconvenience caused by this.
Posted Feb 22, 2021 - 08:42 PST
Investigating
We’ve run into some issues.

Turnitin.com, TurnitinUK.com, iThenticate, SimCheck, Similarity and Originality are currently experiencing an unexpected service degradation. Users accessing the service via an integration may also be affected.

During this time, you may find that Similarity Reports are slow to generate, and logging in to Turnitin via Google SSO, will result in error.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Feb 22, 2021 - 08:27 PST
This incident affected: Americas (US environment) (Turnitin Logins, Report Processing Time), Asia Pacific (Asia Pacific environment) (Turnitin Logins, Report Processing Time), Europe (EU environment) (Turnitin Logins, Report Processing Time), Turnitin (Turnitin Logins, Turnitin Report Processing Time), iThenticate (iThenticate Report Processing Time), and Turnitin UK (Turnitin UK Logins, Turnitin UK Report Processing Time).