Turnitin Status Notification
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected degradation, you may have intermittently received the message “Pool "ev-app-yang-POOL" and some slowness with saving QuickMarks and comments when using Turnitin and TurnitinUK. We are pleased to advise that service has been restored.

The incident occurred between the following times:

BST: April 4th 17:30 - April 6th 12:40
PDT: April 4th 09:30- April 6th 04:40
AEST: April 5th 02:30 - April 6th 21:40

Please accept our apologies if you were impacted by this incident.
Posted Apr 06, 2022 - 05:44 PDT
Monitoring
We are happy to announce that our emergency maintenance has now completed. Turnitin, Turnitin UK and all integrations with these services have been restored.

We are continuing to monitor system performance at this time.

Please accept our apologies for any inconvenience caused during this period.
Posted Apr 06, 2022 - 05:00 PDT
Update
The emergency maintenance is taking a little longer than anticipated, however we are making good progress and hope to have this completed shortly. During this time Turnitin, Turnitin UK and all integrations with these services will be unavailable.

We appreciate your patience at this time.

We will provide further updates when available.
Posted Apr 06, 2022 - 04:07 PDT
Update
We are continuing to investigate this issue.
Posted Apr 06, 2022 - 04:03 PDT
Update
The Emergency maintenance is currently in progress. During this time Turnitin, Turnitin UK and all integrations with these services will be unavailable. We will provide updates as necessary.

We apologize for any inconvenience this may cause.
Posted Apr 06, 2022 - 03:02 PDT
Update
We are continuing to investigate this issue.
Posted Apr 06, 2022 - 01:48 PDT
Update
Users of Turnitin and Turnitin UK may still be intermittently receiving the “Pool "ev-app-yang-POOL" is down” error when viewing submissions. Users of these services may also experience intermittent slowness and/or freezing when applying QuickMarks or commenting on a submission.

In order to restore full service functionality, we will be undertaking an emergency maintenance on April 6th. It is expected to last for 1 hour at the following times:
03:00 PDT
11:00 BST
20:00 AEST

Turnitin, Turnitin UK and all integrations with these services will be unavailable during this time.
Posted Apr 06, 2022 - 00:35 PDT
Update
Turnitin and TurnitinUK are currently experiencing an unexpected service incident.

During this time, you may experience intermittent errors when interacting and grading with Turnitin Feedback Studio.

The earlier slowness issues when accessing both LTI assignments and assignments through Turnitin Feedback Studio, as well as the delays to Translated Matching, should now be resolved.

We are continuing to investigate this as a priority and apologise for the inconvenience caused.
Posted Apr 05, 2022 - 10:44 PDT
Update
We are continuing to investigate.

Turnitin and TurnitinUK are currently experiencing an unexpected service incident.

During this time, you may experience intermittent errors when interacting with Turnitin Feedback Studio.

The earlier slowness issues when accessing both LTI assignments and assignments through Turnitin Feedback Studio, as well as the delays to Translated Matching, should now be resolved.

Please accept our apologies for the inconvenience caused.
Posted Apr 05, 2022 - 09:38 PDT
Update
We are continuing to investigate.

Turnitin and TurnitinUK are currently experiencing an unexpected service incident.

During this time, you may experience intermittent errors when interacting with Turnitin Feedback Studio and delays to Translated Matching.

The earlier slowness issues when accessing both LTI assignments and assignments through Turnitin Feedback Studio should now be resolved.

Please accept our apologies for the inconvenience caused.
Posted Apr 05, 2022 - 08:15 PDT
Update
We are continuing to investigate.

Turnitin and TurnitinUK are currently experiencing an unexpected service incident.

During this time, you may experience intermittent errors interacting with Turnitin Feedback Studio, as well as slowness when interacting with assignments. Users accessing LTI assignments, and using Translated Matching, may also be affected. We are working to resolve this as soon as possible.

Please accept our apologies for the inconvenience caused.
Posted Apr 05, 2022 - 07:42 PDT
Investigating
We’ve run into some issues.

Turnitin and TurnitinUK are currently experiencing an unexpected service incident.

During this time, you may experience intermittent errors interacting with Turnitin Feedback Studio.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Apr 05, 2022 - 04:06 PDT
This incident affected: Turnitin UK (Turnitinuk.com, Turnitin UK Feedback Studio Access, Turnitin UK Feedback Studio Grading Access) and Turnitin (Turnitin.com, Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access).