Slow Similarity Report generation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users of Turnitin and Turnitin UK, as well as those accessing these services via an integration, may have experienced slow Similarity Report generation times. We are pleased to advise that service has been restored.

We encountered a degradation between the following times:

PST Dec 08 21:36 - Dec 09 05:20
GMT Dec 09 05:36 - Dec 09 13:20
AEDT Dec 09 16:36 - Dec 10 00:20

Please accept our apologies if you were impacted by this degradation.
Posted Dec 09, 2020 - 05:47 PST
Monitoring
We’ve run into some issues.

Turnitin.com and Turnitinuk.com are currently experiencing an unexpected service degradation. Users accessing these services via an integration may also be impacted.

During this time, you may find that Similarity Reports are slow to generate.

The root cause has been identified and a fix has been implemented. We are continuing to monitor the situation and will provide an update as soon as the Similarity Report generation times have returned to normal.

Apologies for any inconvenience this may cause.
Posted Dec 09, 2020 - 03:03 PST
This incident affected: Turnitin (Turnitin Report Processing Time) and Turnitin UK (Turnitin UK Report Processing Time).