Slowness in generating a Similarity Report
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have experienced slower Similarity Report generation times in Turnitin Feedback Studio and iThenticate. We are pleased to advise the service has been restored.

The incident occurred between the following times:

PST: December 2nd 21:00 - December 3rd 09:32
GMT: December 3rd 05:00 - December 3rd 17:32
AEDT : December 3rd 16:00 - December 4th 04:32

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Dec 03, 2022 - 10:13 PST
Monitoring
Due to an unexpected service incident, you may be experiencing slower Similarity Report generation times in Turnitin.com, TurnitinUK.com and iThenticate.

We have identified the issue, and we are working to clear the backlog. We invite you to track the progress of this degradation while we work to bring the service back to optimum health. Please accept our apologies for any inconvenience this may cause.
Posted Dec 03, 2022 - 08:58 PST
Identified
Due to an unexpected service incident, you may be experiencing slower Similarity Report generation times in Turnitin.com, TurnitinUK.com and iThenticate.

We have identified the issue, and are continuing to investigate this. We invite you to track the progress of this degradation while we work to bring the service back to optimum health. Please accept our apologies for any inconvenience this may cause.
Posted Dec 03, 2022 - 08:05 PST
Update
We are continuing to investigate this issue.
Posted Dec 03, 2022 - 08:03 PST
Investigating
Due to an unexpected service incident, you may be experiencing slower Similarity Report generation times in Turnitin.com, TurnitinUK.com and iThenticate.

We are currently investigating this issue further. We invite you to track the progress of this degradation while we work to bring the service back to optimum health. Please accept our apologies for any inconvenience this may cause.
Posted Dec 03, 2022 - 05:13 PST
This incident affected: iThenticate (iThenticate Report Processing Time), Turnitin (Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Report Processing Time).