Turnitin Status Notification
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to unforeseen circumstances, you may have been unable to view Similarity Reports in Turnitin and Turnitin UK today. We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PST Feb 17th 02:41 - 03:49
GMT Feb 17th 10:41 - 11:49
ADST Feb 17th 21:41 - 22:49

Please accept our apologies if you were impacted by today’s disruption.
Posted Feb 17, 2020 - 04:58 PST
Monitoring
Users of Turnitin and Turnitin UK may be unable to load Similarity Reports. We believe we have located the root cause of this issue and are working to implement a fix. Most users are currently able to load Similarity Reports without issue.
Posted Feb 17, 2020 - 04:11 PST
Investigating
We’ve run into some issues.

Turnitin and Turnitin UK are currently experiencing an unexpected service disruption.

During this time, you may find that you are unable to view Similarity Reports.

We invite you to track the progress of this disruption while we work to bring service back to optimum health.
Posted Feb 17, 2020 - 03:34 PST
This incident affected: Turnitin (Turnitin Report Processing Time) and Turnitin UK (Turnitin UK Report Processing Time).