Due to an unplanned key rotation by Instructure following the security incident posted here (https://status.instructure.com/incidents/9wm4knj2r64z), users might have been unable to access or generate similarity reports via Canvas LMS submitted via Canvas Plagiarism Framework (CPF). We are pleased to advise that service has been restored.
Affected products:
Turnitin Turnitin UK Turnitin Similarity, Originality and SimCheck
The incident occurred between the following times:
PDT: May 1st, 2026 - Friday, 15:30 to May 4th, 2026 - Monday 14:10 BST: May 1st, 2026 - Friday, 23:30 to May 4th, 2026 - Monday 22:10 AEST: May 2nd, 2026 - Saturday, 8:30 - May 5th, 2026 - Tuesday 7:10
Please note that Canvas will resubmit the affected submissions; it is worth noting that this may take a while to complete.
We regret any inconvenience this may have caused if you were impacted by the incident.
Posted May 04, 2026 - 15:09 PDT
Identified
We’ve run into some issues.
Due to an unplanned key rotation by Instructure following the security incident posted here (https://status.instructure.com/incidents/9wm4knj2r64z), users will encounter issues accessing reports via Canvas LMS submitted via Canvas Plagiarism Framework (CPF).
Affected products: Turnitin Turnitin UK Turnitin Similarity, Originality and SimCheck
Posted May 04, 2026 - 07:32 PDT
This incident affected: Americas (US environment) (Report Processing Time), Europe (EU environment) (Report Processing Time), Asia Pacific (Asia Pacific environment) (Report Processing Time), Turnitin (Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Report Processing Time).