Current View Report and Digital Receipt Issues
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users of Turnitin, Turnitin UK and iThenticate, as well as those accessing these services via an integration, may have experienced slowness and time-out issues when attempting to download the Current View and the Digital Receipt for their Similarity Reports. Similarity Report generation and access to reports were not affected.

We are pleased to advise that service has been restored.

We encountered a degradation between the following times:

PST March 5 04:30 - March 5 09:30
GMT March 5 12:30 - March 5 17:30
AEDT March 5 23:30 - March 6 04:30

Please accept our apologies if you were impacted by today’s degradation.
Posted Mar 05, 2021 - 09:52 PST
Investigating
We’ve run into some issues.

Turnitin, Turnitin UK & iThenticate are currently experiencing an unexpected service disruption, users accessing these services via an integration, may also be affected.

During this time, you may experience slowness and time-out issues when attempting to download the Current View and the Digital Receipt for your Similarity Reports. Similarity Report generation and access to reports are not affected.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Mar 05, 2021 - 07:49 PST
This incident affected: iThenticate (iThenticate Report Processing Time), Turnitin UK (Turnitin UK Paper Submissions), and Turnitin (Turnitin Paper Submissions).