There is an issue with Similarity and Turnitin Core API in the US region
Incident Report for Turnitin
Resolved
Due to an unexpected disruption, users may have been unable to access and experienced delays in report generation through Turnitin Similarity, and Turnitin Core API. Users accessing these services via an integration would also have been impacted. We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PDT May 12th 17:23 - 19:25
BST May 13th 01:23 - 03:25
AEST May 13th 10:23 - 12:25

Please accept our apologies if you were impacted by today's disruption.
Posted May 12, 2020 - 19:27 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 12, 2020 - 18:37 PDT
Investigating
We are investing the issue with slow logins, and unresponsive API integrations.
Posted May 12, 2020 - 17:23 PDT
This incident affected: Americas (US environment) (Turnitin Logins, Paper Submissions, API).