Issues with Receiving Emails
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service disruption, users of Turnitin may have been unable to receive submission receipts, password resets or welcome emails. We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PDT Sep 22 10:15 - Sep 25 05:45
BST Sep 22 18:15 - Sep 25 13:45
AEST Sep 23 03:15 - Sep 25 22:45

If you need assistance with accessing your submission receipt or logging in, please contact Turnitin Support: https://supportcenter.turnitin.com/s/

Please accept our apologies if you were impacted by today’s disruption.
Posted Sep 25, 2020 - 06:24 PDT
Investigating
We’ve run into some issues.

Turnitin is currently experiencing an unexpected service disruption.

During this time, you may find that some users are unable to receive submission receipts, password resets or welcome emails.

Our engineers are actively investigating the incident. We apologize for the inconvenience and thank you for your patience. For updates, please visit https://turnitin.statuspage.io/
Posted Sep 25, 2020 - 05:33 PDT
This incident affected: Turnitin (Turnitin Logins).