Delayed Similarity Report generation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, users may have experienced slower than usual Similarity Report generation when using SimCheck, Similarity, Crossref Similarity Check and Originality. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PST: January 4th 09:16 - January 4th 09:49
GMT: January 4th 17:16 - January 4th 17:49
AEDT: January 5th 03:16 - January 5th 03:49

Please accept our apologies if you were impacted by today’s incident.
Posted Jan 04, 2022 - 10:36 PST
Investigating
We’ve run into some issues.

SimCheck, Similarity, Crossref Similarity Check and Originality are currently experiencing an unexpected service incident. During this time, you may find that Similarity Report generation is taking longer than expected.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Jan 04, 2022 - 10:04 PST
This incident affected: Europe (EU environment) (Report Processing Time, API).