Similarity Report generation delays
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users of Turnitin, Turnitin UK and iThenticate, as well as those accessing these services via an integration, may have experienced delays in the generation of their Similarity Reports today. We are pleased to advise that service has been restored.

We encountered a degradation between the following times:

PDT August 4th 22:19 - August 5th 04:15
BST August 5th 06:19 - August 5th 12:15
AEST August 5th 15:19 - August 5th 21:15

Please accept our apologies if you were impacted by today’s degradation.
Posted Aug 05, 2021 - 05:27 PDT
Update
A fix has been implemented, whereby Similarity Report generation times have now returned to normal, but we are continuing to monitor the results to ensure no further issues arise.
Posted Aug 05, 2021 - 05:17 PDT
Update
A fix has been implemented, whereby Similarity Report generation times are returning to normal, but we are continuing to monitor the results.
Posted Aug 05, 2021 - 04:15 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 05, 2021 - 03:13 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 05, 2021 - 02:04 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 05, 2021 - 01:07 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2021 - 00:36 PDT
Update
We are continuing to investigate this issue.
Posted Aug 04, 2021 - 23:56 PDT
Investigating
We’ve run into some issues.

Turnitin, TurnitinUK and iThenticate are currently experiencing an unexpected service disruption.

During this time, you may find that you may experience delayed report-generation times for your Similarity Reports.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Aug 04, 2021 - 23:56 PDT
This incident affected: iThenticate (iThenticate Report Processing Time), Turnitin (Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Report Processing Time).