Turnitin.com and Turnitinuk.com inaccessible
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service outage, Turnitin, TurnitinUK and integrations users may have not been able to access the service, experienced slowness and extended report generation times. We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PDT Oct 20 06:40 - Oct 20 10:30
BST Oct 20 14:40 - Oct 20 18:30
AEDT Oct 21 00:40 - Oct 21 04:30

Please accept our apologies if you were impacted by today’s disruption.
Posted Oct 20, 2020 - 12:16 PDT
Update
We believe that the main issue affecting users logging into the service has now been resolved.

Users may experience slowness while using the service and see extended report generation times as the system recovers.

Please accept our apologies for any inconvenience this may have caused.
Posted Oct 20, 2020 - 10:06 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2020 - 09:35 PDT
Update
We believe the main issue affecting users logging into the service has been resolved.
Users may experience slowness while using the service as the system recovers.
Please accept our apologies for any inconvenience caused.
Posted Oct 20, 2020 - 08:45 PDT
Monitoring
We’ve implemented a fix for the power failure in one of our data centers and are currently monitoring the service as it recovers.

We will update you as soon as full functionality has been restored.

Please accept our apologies for any inconvenience caused.
Posted Oct 20, 2020 - 08:31 PDT
Update
We’re investigating a potential power failure in one of our data centers.

Users accessing turnitin.com or turnitinuk.com may not be able to access these services.
Users accessing these services via an integration may also be affected. We are currently working to resolve this issue.

Please accept our apologies for any inconvenience caused.
Posted Oct 20, 2020 - 07:31 PDT
Update
We are continuing to investigate this issue.
Posted Oct 20, 2020 - 07:06 PDT
Update
We are continuing to investigate this issue.
Posted Oct 20, 2020 - 07:03 PDT
Investigating
We’ve run into some issues. Users accessing turnitin.com or turnitinuk.com may not be able to access these services. Users accessing these services via an integration may also be affected. We are currently working to resolve this issue. Please accept our apologies for any inconvenience caused.
Posted Oct 20, 2020 - 07:00 PDT
This incident affected: Turnitin UK (Turnitin UK Logins, Turnitin UK Report Processing Time) and Turnitin (Turnitin Logins, Turnitin Report Processing Time).