Delayed Similarity Report Generation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, users of Turnitin, TurnitinUK, Turnitin Similarity, SimCheck, Originality, Crossref Similarity Check, iThenticate, and those accessing these services via an integration might have experienced slow Similarity Reports generation. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT: April 3rd 15:24 - April 3rd 18:10
BST: April 3rd 23:24 - April 4th 02:10
AEST: April 4th 08:24 - April 4th 11:10

Please accept our apologies if you were impacted by today’s incident.
Posted Apr 03, 2022 - 19:04 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2022 - 17:58 PDT
Identified
We’ve run into some issues.

Turnitin, TurnitinUK, Turnitin Similarity, SimCheck, Originality, Crossref Similarity Check and iThenticate are currently experiencing an unexpected service incident.

During this time, you may find that submissions take longer than expected to generate Similarity Reports.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Apr 03, 2022 - 17:33 PDT
This incident affected: Draft Coach (Draft Coach Report Processing Times), iThenticate (iThenticate Report Processing Time), Crossref Similarity Check ((v1) Similarity Reports Generation, (v2) Similarity Reports Generation), Americas (US environment) (Report Processing Time), Turnitin UK (Turnitin UK Report Processing Time), and Turnitin (Turnitin Report Processing Time).