Turnitin Maintenance March 12 2021
Incident Report for Turnitin
Resolved
Turnitin Feedback Studio, is back to fully functionality as all services have now been restored. Thank you for your patience as we worked to resolve this matter, and we regret any inconvenience this may have caused.
Posted Mar 12, 2021 - 14:01 PST
Identified
Emergency Maintenance is complete. For all customers using Turnitin Feedback Studio, we have restored the ability to submit papers and view similarity scores, access submissions, and use grading tools. Details of student paper matches in the similarity report are not currently available. We regret any inconvenience this may have caused as we continue to investigate and work towards complete service restoration.
Posted Mar 12, 2021 - 11:28 PST
Investigating
Turnitin is currently undergoing Emergency Maintenance. Turnitin services will be inaccessible during this period. We apologize for the inconvenience.
Posted Mar 12, 2021 - 09:32 PST
This incident affected: Turnitin UK (Turnitinuk.com, Turnitin UK Logins, Turnitin UK Paper Submissions, Turnitin UK Report Processing Time, Turnitin UK Feedback Studio Access, Turnitin UK Feedback Studio Grading Access) and Turnitin (Turnitin.com, Turnitin Logins, Turnitin Paper Submissions, Turnitin Report Processing Time, Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access).