Unexpected service degradation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users of Turnitin Similarity, SimCheck, Originality, Crossref Similarity Check, and Turnitin Draft Coach may have been unable to log in and/or view similarity reports. Users accessing these services via an integration may have also been affected.

We are however pleased to advise that service has been restored.

The service degradation occurred between the following times:

PDT Wednesday, Nov 3, 2021 14:29-15:08
GMT Wednesday, Nov 3, 2021 21:29-22:08
AEDT Thursday, Nov 4, 2021 08:29-09:08

Please accept our apologies if you were impacted by today’s degradation.
Posted Nov 03, 2021 - 15:46 PDT
Investigating
We’ve run into some issues.

Turnitin Similarity, SimCheck, Originality, and Crossref Similarity Check are currently experiencing an unexpected service degradation. During this time, some users may experience issues logging in or viewing Similarity reports when accessing these services via an integration. Some users of Turnitin Draft Coach may also find they are unable to view Similarity reports.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Nov 03, 2021 - 15:16 PDT
This incident affected: Americas (US environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), Europe (EU environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), Asia Pacific (Asia Pacific environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), and Crossref Similarity Check ((v1) Website Logins, (v1) Similarity Reports Generation, (v1) API, (v2) Website Logins, (v2) Paper Submissions Processing, (v2) Similarity Reports Generation, (v2) API).