Unable to make submissions via Google Drive
Incident Report for Turnitin
Resolved
The issue with making submissions via Google Drive has been resolved.

We encountered the disruption between the following times:

PST February 18th 07:19 - 13:04
GMT February 18th 15:19 -21:04
AEDT February 19th 02:19 - 08:04

Please accept our apologies if you were impacted by this disruption.
Posted Feb 18, 2020 - 13:48 PST
Update
We’ve fixed it!

Please accept our apologies if you were impacted by today’s disruption.
Posted Feb 18, 2020 - 13:44 PST
Monitoring
We are currently working on implementing a solution. We apologize for the inconvenience and thank you for your patience.
Posted Feb 18, 2020 - 10:18 PST
Identified
Turnitin and Turnitin UK users may be unable to submit via Google Drive.

Our engineers believe they have identified the root cause of the issue and are working to resolve this as our top priority.

We apologize for any inconvenience caused.
Posted Feb 18, 2020 - 08:46 PST
Update
Turnitin and Turnitin UK are currently experiencing an unexpected service disruption.

Users may not be able to make submissions via Google Drive.

We are continuing to investigate this issue as a priority and hope to have a resolution soon.

Apologies for any inconvenience this may be causing.
Posted Feb 18, 2020 - 08:15 PST
Investigating
We’ve run into some issues.

Turnitin and Turnitin UK are currently experiencing an unexpected service disruption.

During this time, you may find that you are unable to make submissions via Google Drive.

We invite you to track the progress of this disruption while we work to bring service back to optimum health.
Posted Feb 18, 2020 - 07:39 PST
This incident affected: Turnitin UK (Turnitin UK Paper Submissions) and Turnitin (Turnitin Paper Submissions).