Degraded Performance - Europe
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, you may have experienced a delay in report generation today. We are pleased to advise that service has been restored.

We encountered a degradation between the following times:

PDT Sep 08 23:30 - Sep 09 02:00
BST Sep 09 07:30 - Sep 09 10:00
AEST Sep 09 16:30 - Sep 09 19:00

Please accept our apologies if you were impacted by today’s degradation.
Posted Sep 09, 2021 - 02:37 PDT
Investigating
We’ve run into some issues.

Originality, Similarity and Simcheck are currently experiencing an unexpected service degradation.

During this time, you may find that generating reports will take longer than usual.

We invite you to track the progress of this degradation while we work to bring the service back to optimum health.
Posted Sep 09, 2021 - 02:08 PDT
This incident affected: Europe (EU environment) (Report Processing Time).