Report Generation - Europe
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users of our services in Europe may have been unable to generate a Similarity Report in Crossref Similarity Check, SimCheck, Similarity and Originality today. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT Nov 5th 07:36 - 09:00
GMT Nov 5th 14:36 - 16:00
AEDT Nov 6th 01:36 - 03:00

Please accept our apologies if you were impacted by today’s incident.
Posted Nov 05, 2021 - 09:30 PDT
Investigating
We've run into some issues.

Crossref Similarity Check, SimCheck, Similarity and Originality are currently experiencing an unexpected service degradation.

During this time, you may find that Similarity Reports are not generating for submissions.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Nov 05, 2021 - 08:08 PDT
This incident affected: Europe (EU environment) (Report Processing Time) and Crossref Similarity Check ((v2) Similarity Reports Generation).