Issue with slow submissions
Incident Report for Turnitin
Resolved
We’ve fixed it!

You may have experienced issues with uploading and viewing submissions today. This was the result of a service degradation affecting the performance of Turnitin's Feedback Studio and iThenticate.

We encountered a disruption between the following times:

PDT 18:30 - 22:50 April 19th
GMT 01:30 - 05:50 April 20th
AEST 11:30 - 15:50 April 20th

We are pleased to announce that this has now been resolved.
We sincerely apologize for the inconvenience caused.
Turnitin engineers continue to monitor the system.
Thanks for your patience!
Posted Apr 19, 2020 - 23:36 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2020 - 22:52 PDT
Update
We are continuing to investigate this issue.
Posted Apr 19, 2020 - 20:14 PDT
Update
We are continuing to investigate this issue.
Posted Apr 19, 2020 - 19:59 PDT
Investigating
We are currently investigating an incident with slow submissions.
Posted Apr 19, 2020 - 18:30 PDT
This incident affected: iThenticate (iThenticate Report Processing Time) and Turnitin (Turnitin Report Processing Time).