Turnitin Service Incident - 22 April
Incident Report for Turnitin
Resolved
Due to an unexpected service incident, users of Turnitin, Turnitin UK, iThenticate, Crossref, Turnitin Similarity, Originality, and SimCheck may have found a delay in Similarity Report generation.

We are pleased to inform that the service has been restored.

The incident occurred between the following times:

PDT: April 21, 22:20 PM - April 23, 11:45
BST: April 22, 06:20 - April 23, 19:45
AEST: April 22, 15:20 - April 24, 04:45

We regret any inconvenience this may have caused if you were impacted by the incident.
Posted Apr 23, 2024 - 12:27 PDT
Monitoring
A fix has been implemented, and we are monitoring the results.

There may be delays in report generation while we work through a backlog caused by the incident.

This is impacting our users accessing Turnitin, Turnitin UK, iThenticate, Crossref, and via an integration. Turnitin Similarity, Originality, and Simcheck in the Americas may also be affected.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Apr 22, 2024 - 13:53 PDT
Identified
We’ve run into some issues.

Turnitin, Turnitin UK, iThenticate, Crossref, and users accessing Turnitin via an integration are continuing to experience an unexpected service incident. Users accessing Turnitin Similarity, Originality, and Simcheck in the Americas may also be affected.

During this time, you may experience slowness in Similarity Report generation.

We invite you to track the progress of this incident while we work to bring the service back to optimum health
Posted Apr 22, 2024 - 11:40 PDT
Monitoring
A fix has been implemented, and we are monitoring the results.

There may be delays in report generation while we work through a backlog caused by the incident.

This will impact users accessing Turnitin, Turnitin UK, iThenticate, Crossref, and via an integration.

Turnitin Similarity, Originality, Simcheck in the Americas may also be affected.
Posted Apr 22, 2024 - 04:21 PDT
Identified
We’ve run into some issues.

Turnitin, Turnitin UK, iThenticate, Crossref, and users accessing Turnitin via an integration are currently experiencing an unexpected service incident. Users accessing Turnitin Similarity, Originality, Simcheck in the Americas may also be affected.

During this time, you may experience slowness in Similarity Report generation.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Apr 21, 2024 - 23:04 PDT
This incident affected: iThenticate (iThenticate Report Processing Time), Crossref Similarity Check ((v1) Similarity Reports Generation, (v2) Similarity Reports Generation), iThenticate 2.0 (iThenticate Report Processing Time), Americas (US environment) (Report Processing Time), Turnitin (Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Report Processing Time).