Downloading Similarity Report Issue
Incident Report for Turnitin
Resolved
We’ve fixed it!

Turnitin, Turnitin UK, iThenticate, Crossref, SimCheck, Similarity and Originality users, as well as those accessing the service via an integration, may have experienced difficulty downloading the Similarity Report. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT: April 27th 17:51 - April 27th 21:38
BST: April 28th 01:51 - April 28th 05:38
AEST: April 28th 10:51 - April 28th 14:38

Please accept our apologies if you were impacted by today’s incident.
Posted Apr 27, 2022 - 21:53 PDT
Investigating
We’ve run into some issues.

Turnitin, Turnitin UK, iThenticate, Crossref, SimCheck, Similarity and Originality, as well as those accessing the service via an integration, are currently experiencing an unexpected service incident.

During this time, users may be unable to download the Similarity Report.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Apr 27, 2022 - 20:18 PDT
This incident affected: Draft Coach (Draft Coach Paper Submissions), iThenticate (iThenticate Report Processing Time), Americas (US environment) (Paper Submissions), Europe (EU environment) (Paper Submissions), Asia Pacific (Asia Pacific environment) (Paper Submissions), Crossref Similarity Check ((v1) Similarity Reports Generation, (v2) Similarity Reports Generation), Turnitin (Turnitin Paper Submissions), and Turnitin UK (Turnitin UK Paper Submissions).